Windows 10 Technical Preview Build 10130 – Release Candidate or Train Wreck?


#1

This is the sad tale of my few days spent as an unpaid beta tester for Microsoft’s Windows 10 Pro Insider Preview, Build 10130. This is the build for which, according to Neowin, “Microsoft has made it clear that this build - and future ones - will focus less on delivering major new features to the operating system, and more on adding polish and stability ahead of its release this summer”. If you are prone to depression, or of a sensitive nature, you may not wish to read the whole piece, so I shall summarise my conclusions for you. This build, which should be of the standard of a Release Candidate, given that the official release is set for the end of July, is not fit for purpose. Any purpose. To all intents and purposes, it works so badly that it is unusable. It is disgraceful software. To borrow a phrase from Monty Python, it is the software equivalent of a dead parrot.

That’s it. You can turn your attention elsewhere now. Expect a functional version of Windows 10 in a few months, maybe; don’t hold your breath though.

So, for the masochistic, here’s the story. You would expect an operating system due for public release in just over a month to be virtually wrapped up, all its basic functions firm and reliable, with a few rough edges to be smoothed off in the remaining few weeks, would you not? So I thought on Sunday 14 June, when I decided to have another look at Windows 10, set up on my multi-booting HP EliteBook 8540w (Core i7, 8 GB RAM, one SSD, one HD, standard MBR partitioning). This system has been happily triple-booting Windows 7, Linux Mint 17.1 Cinnamon, and earlier versions of Windows 10 for several months now. The most recent Windows 10 build I had installed was 10074. It looked promising, although I was at a loss to understand what all the fuss was about really.

At the time I wasn’t aware of Build 10130; I just thought I would start by updating my system to the next build on the Fast Ring. So I did that, and initially it all looked OK, although the taskbar no longer autohid. Right-clicking on the taskbar allowed me to change the search box to an icon, but autohide still wouldn’t work, and the Start Menu came up only a couple of times before deciding it had had enough. Clicking an icon on the taskbar produced nothing. I managed to get Settings up so I could run Updates, but after that everything went pear-shaped, and even Restart didn’t work. I had to use the physical Power button to reboot. It’s had more use in the last few days than it has for months. Logging in again got me no further towards a working system. So I decided that the update process must have failed, and I would have to do a clean installation. I went to the Microsoft website to check whether there was an ISO later than 10074 , and discovered that the site is now offering Build 10130, including a GB (UK) build, so I downloaded and burnt that to (fortunately) rewritable DVD. Then I did a clean installation, making sure to delete and recreate the installation partition during the procedure.

I won’t bore you with the history of that installation and the next. I got systems that wouldn’t do anything much; Start menus that wouldn’t; taskbars from which no task could be achieved, not even right-clicking to start Task Manager; instances of Task Manager (eventually) which would not manage, or end, any tasks or processes, and eventually themselves ended up “not responding”; systems which gradually died, refusing to allow any programs to run for much longer than it took to display “not responding” in the title bar. In no case was I able to restart the system using the Restart option; the Power button quickly lost its layer of dust.

To add injury to insult, the OS eventually trashed the MBR, so I couldn’t boot anything. Using the OS installation disk, I initiated an AutoRepair. Has that ever worked, for anyone? For me, System Restore and AutoRepair have never worked, ever. Well, OK, there was the once, but it was a few years ago. They always result in a long wait, after which Windows comes back and unapologetically says it couldn’t actually achieve anything, and perhaps I should try something else. Ring a friend, perhaps. Couldn’t do it? This is not rocket science, just a simple MBR reset, like GRUB does routinely.

After a bit of messing about, I recovered my MBR manually, so I could get back into Windows 7 and Linux. But two clean installations later I still couldn’t get a working W10 system. Sometimes I couldn’t get beyond the lock screen. Sometimes login wouldn’t go beyond typing in the PIN or password. Sometimes it wouldn’t even let me type the PIN or password. And after the initial installation and updating stage, never ever did Restart or Shutdown work. Never. Not once. Programs installed, ran for a while, then froze. OneDrive proved almost impossible to configure. Behaviour was slightly different between installations, but always bad. At one stage, the OS was automatically running CHKDSK at every boot for every NTFS partition it could find, and finding errors to correct too.

So I thought I would write up the sorry mess to present to you happy few, you band of brothers, but before that I would do one final clean installation and take notes. Today I did that. Here we go, one last time.

Windows 10 Installation - The Final Cut.

Installation proceeds normally; I log in to my Microsoft account and set a PIN during the process. The system sets up my standard desktop background and ID icon. I repeatedly Update from Settings until no more are presented. At least I don’t get the dreaded Error 0x80070103 any more, not sure why. Why can’t Microsoft just say straight out that this error is probably due to trying to install a driver that was already installed, instead of my needing to Google the error number? I set build updating to Fast. I eventually find where the option to display desktop icons has been hidden (deep in Settings | Display | Themes; why not make it as awkward as possible?)

At the moment I can start Explorer from the taskbar, so I do so and start the process of redirecting system folders like Documents from C:\Users\Martin to my D: drive, where the folders are set up as D:\Martin\Documents, etc. I always keep my data on a separate partition. That works OK, but I am going to need to change the security permissions on D: to ensure programs and I have full access. There the problems start: the properties dialogs for D: will not let me enter, i.e. type in, a new security principal. I have to reboot to get normal access to the security settings. During reboot, I get, as I often do, an explorer.exe error on exit (memory could not be read). At least Restart worked this time. More messing about with security settings and ownership turns out to be necessary before I can get access to Documents, Music, etc.

I note here that the OS has taken to using the first few letters of my email address as the User, i.e. my user folder is C:\Users\j_m_w instead of C:\Users\Martin. This is presumably because I put in my Microsoft ID during installation, but the system must still have known my first name, since it presents it at login. Also I can’t find myself as a security principal under Martin, only under j_m_w. Weird. (Well, stupid, actually).

Now I use Settings to ensure all the system and taskbar icons are shown in the notification area, so I can see what’s going on there. I start the Task Manager by right-clicking on the taskbar, because I know I’m going to need it. In the course of messing around, I get two Control Panel windows, one containing only the message “Page failed to load”. Never mind.

I install Core Temp so that I can keep an eye on the processor temperatures, which have been known to get a bit high in the past but have been fine during these tests - think my heat sink needs replacing, the heat pipe’s probably low on gas. Also install Networx, so I can check download rates when updating. Then install EaseUS Todo Backup Free 8.3, so I can back up the OS to external USB HD, and maybe save a bit of time if another reinstallation becomes necessary. Also enable .NET 3.5 and install Windows Live Mail. At first WLM works fine and downloads my Hotmail. Then I try to change the mail Store Folder to one on the D: drive; at the end of the procedure wlmail.exe locks up, and Task Manager refuses to kill it. Eventually Task Manager refuses to do anything at all, and becomes unresponsive. By now Networx has frozen - the graph display has stopped moving. Ctrl-Alt-Del, as is usual with this OS, does nothing. Restart does not work when selected from the Start Menu. Then the Start Menu won’t come up any more, although right-clicking on the Start icon brings up a menu from which Restart can be selected. But that doesn’t work either. Long press on the Power button. Leave the system to reboot.

Return to the PC to log in, but I left it too long. The lock screen lifts OK (sometimes it has literally locked in place), but when I type in my PIN, nothing happens. I select password entry instead, but no input box is presented, and still nothing happens. I select the power icon and Restart, but it doesn’t work. Nothing happens. Long press the Power button. Again. This time I wait and log in straight away.

Core Temp comes up fairly quickly, but Networx takes a while, for some reason. This OS is supposed to be fast?

I decide to install Firefox. Installation goes OK, but when Firefox gives me the option to make it the default browser, Windows refuses to do so, and says I have to go to the Settings | System page (I think) and do it myself. Gee thanks. I try to sign in to Firefox Sync, but the Firefox title bar is displaying “not responding” before I can complete the sign-in. I try to kill Firefox with Task Manager, but pressing End Task does exactly nothing except begin the process of locking up Task Manager. Task Manager “not responding”? WTF? Shouldn’t Task Manager be beyond that sort of thing?

Networx stops. The taskbar has become unresponsive, and the Start Menu will not come up. I just get the circular “timer” cursor when I hover it over the area. Core Temp is still going. Think positive. But nothing works now. Reboot - using the Power key. Again.

This time, I log in quickly and am immediately confronted with “We couldn’t find the location of your OneDrive folder.” Serves me right for having relocated it to the D:drive, I suppose. I select to Reconfigure, and enter my Microsoft ID (why? The system already has it) but the reconfiguration process stops at “Sync your OneDrive files to this PC” … “loading your list of folders”. Closing the dialog box and clicking on the OneDrive taskbar icon to restart the process gives no result. Left- or right-click on the icon - nothing. Try using Task Manager to stop OneDrive so I can restart it - doesn’t work.

Networx has stopped. Select Start Menu, Power, Restart - no highlight on Restart, no response. Right-click on Start icon, Shut down or restart, select restart. No response.

Hard reboot - again.

Log in, presented immediately with OneDrive setup dialog. It works this time, so I let it set up OneDrive on C: to avoid further trouble. Note that, amazingly, this version of OneDrive is dated 2013; that is to say, it is the version shipped for Windows 7. In an RC version of the operating system, critically dependent on an updated OneDrive for its success, shouldn’t Microsoft be doing a little better than this? Whatever happened to the useful file placeholder system in Windows 8.1? That would have been really good if a file or folder’s online/offline status had been more clearly indicated.

I go to Settings | System to change the default browser to Firefox, which works OK. Then I try to go to Settings | Updates, but Settings locks up just as I select Updates, so I can’t get in there.

I try to log in to Firefox Sync again, and get as far as typing one character of the login before Firefox goes to “not responding”. Networx has frozen again. I can’t do anything with the taskbar or reach the Start Menu. I try to use the Task Manager to kill Firefox, but nothing happens. Eventually a little box comes up with “Microsoft Windows - the application is not responding”! Microsoft Windows is not responding! You can say that again. I select “End Process” for kicks, but nothing happens.

I select the Start Menu, press Power. No result. I click away, then click the Start icon again. No Start Menu. I right-click the Start icon, and get the menu for shutdown or restart, but choosing Restart just puts the cursor into circular “waiting” mode, so guess what? Long press on the Power button. Again.

This time, I decide to reboot into Windows 7 to try to restore my sanity. Windows 7 promptly starts CHKDSK, which scans every NTFS partition, and corrects various errors that it finds, including in the master file table for D:. How did D: get corrupted? I am starting to get really cross now. I eventually get into the much more pleasant environment of Windows 7, with its restful Aero windows, and start to fix the permissions on D: so it can be reached properly from both W7 and W10.

Now I boot into Linux Mint 17 Cinnamon - a really pleasant environment, set up with Variety to be pretty to look at, where everything works, and works fast. I do a quick apt-get update/upgrade, just for the hell of it.

Now I reboot, and leave the machine to boot back into W10. Unfortunately I again leave it too long before coming back to the PC, and although I can enter the PIN, login doesn’t happen. Selecting Restart doesn’t work. Power switch reboot - again. This time the PIN works and it looks as if login is proceeding - but no, the little spinning circle of white dots just stops.

Power switch reboot. Again.

This time, I get in, but I can’t get any sense out of OneDrive, which seems not to be working at all. I run Firefox to try to sign in to Sync, but suddenly it is - guess what? - “not responding”.

The cursor is now a spinning circle. The taskbar is not usable. The Start Menu is not accessible. Core Temp has stopped (with a low temperature indicated). Networx has stopped.

I have stopped. Windows 10 Build 10130 is a disgrace. Shame on Microsoft for accepting the goodwill and input of hundreds, if not thousands, of people and rewarding them with this rubbish. Shame on Microsoft if the best example it can give of the use it has made of that input is to implement a new window button and move it about on the title bar.

In postscript, I am surprised that no-one else seems to have reported suffering in the same way. If I could have repeated the tests on another computer, I would have, but if it had run W10 satisfactorily, that would still leave the question of how the 8540w could run Windows 7, Linux Mint, and all previous builds of Windows 10, but not this build.


#2

This is interesting… I haven’t seen any of the problems you’re describing on my Windows 10 test machine. What you’re describing sounds almost exactly like what happens on my gaming rig when the hard drive controller acts up. The mouse moves, and dynamic screen events work, but anything that has to access the hard drive just sort of sits there, doing nothing.

Actually, it’s precisely the opposite. I’m familiar with software development from the inside, and at 6 weeks out from release, you’re already in Crunch Mode, and engineers are working somewhere around 60 hours a week at this point, trying to get the last of the major problems solved.

I agree with you on this. AutoRepair is the worst. I’d much rather have a menu of things to do, rather than a black-box process that doesn’t give me any feedback about what’s going on.

This was standard on Windows 8. If I recall, my first Windows 8 system with a Microsoft account decided to name my account “wilsontp_5667980” or something similar. I resolved this by disconnecting the account, changing the username to my first name, then reconnecting the account to my Microsoft account. Ideally, Microsoft should ask for a local account name, rather than generating one itself.


#3

Thanks for your comment - last point first: yes, I too have resolved this one previously in the way you describe, but Build-10130-rage induced me to throw it in. The user should not have to think of work-arounds.

First point last: I’ve worked on individual software product development projects that have gone up to the wire, and made the deadline thanks to last-minute problem-solving, but this is a whole huge operating system with a global impact, which requires extensive testing, documentation, and QA well after the actual software engineering is over. There is no way that proper project management should be permitting any major changes after say a couple of weeks from now with a declared release date of 29 July, and they should really all have been done by now. The current state of the project indicates that either the release will be sub-standard, or it will be delayed, potentially very considerably, as I suggest above.

I have gradually gained the impression that the project management team doesn’t really know what it is doing, or more accurately, what it is supposed to be doing. There don’t appear to be any clear goals, and the work seems to be around the edges, bolting on extras and fiddling with cosmetics, instead of integrating the whole. The GUI should have been decided, planned and finished weeks ago, but they still seem to be fiddling around with it. Note that Stardock managed to produce a Windows 7 GUI, including Aero effects, for Windows 8/8.1, as well as resizeable windows for apps (Modern Mix), within a relatively short time after the release of Windows 8, presumably without much help from Microsoft, but they had clear goals and, it would appear, excellent engineers. I continue to use this, and it’s much better than any Windows 10 desktop I’ve seen so far.

I have come to the conclusion that the basic core of Windows remains essentially the Windows 7 code. Windows 8 “fast boot”, for instance, turns out to have been a modification of the hibernation functionality, for no particularly good reason apart from a marketing ploy. And what on earth is happening to OneDrive? It is essential that it is developed in the right way, yet there is no sign of a development version; Windows 10 still only includes OneDrive 2013, without even the integration of Windows 8.1.

Unfortunately, there is little evidence that the enthusiastic support from Microsoft’s customers in the Insider program is actually diverting it from its usual modus operandi of PR hype covering development ineptitude.

But I digress - are you saying that you are currently running Build 10130 without any problems? If so, are you using any special BIOS settings for the processor, because that’s the only possibility that I can think of that might affect my machine? I don’t think there are any hard drive controller problems, because the other OSs work OK, and in any case all the relevant partitions are on an SSD.


#4

Yes. The computer is a 2 year-old Lenovo i7 system. I haven’t changed any of the BIOS settings; the only thing I’ve changed in the BIOS settings is to turn on hardware virtualization, since I bought the Windows 8.1 Professional upgrade on that machine to run Hyper-V VM’s.


#5

Thanks. That’s really weird. I’ve got Virtualization Technology turned on as well. Data Execution Prevention is turned on, but that’s normal, I think. There’s some other stuff that I don’t understand, to do with security and the TPM, but I don’t think that should affect program execution. And although the laptop can run a bit hot, it’s usually well within the limits, and switches itself off if necessary. Looks like this will remain a mystery, unless someone comes up with an answer to the similar rant that I posted to the Insider Forum.


#6

@jmward, I’m running a duel boot with Windows 7 and 10, on a self built i5 system. No problems what so ever with Windows 10.


#7

@ronniesonora
Thanks for your reply. Yes, I am beginning to realise that there are people having no trouble with Build 10130. So why me? The “Get Windows 10” utility (Windows 7) tells me that for the 8540w “You’re good to go!”. And why the problems now when there weren’t any before? Windows 10 is touted as being able to run on almost any reasonably recent machine. My laptop spec is well above average, I would have thought. Core i7, 8GB RAM, mobile NVIDIA processor Quadro FX 880M.


#8

This is a sad story only 6 weeks before RTM. Let’s hope that you are an unfortunate exception. In my 35 years of operating system development (large host systems) I have never seen so many problems this close to release to customers.

I run 10130 in VMware Player and did not encounter any serious problems yet. But I did not do anything exceptional yet either. Just light testing of the basic functions. Let’s hope that Wilson’s and my experience are the base case. Else it would be a disaster for Windows 10.


#9

Unlike the OP, I remained on the Insider Slow Ring and have had surprisingly few problems with Win 10 Pro Insider Preview build 10130. Some of the Apps do not work completely (e.g. Flixster) but this may be because Flixster will not roll out their new App until the OS goes ‘gold’. On the other hand the Netflix app works great. Based on my experiences so far I would recommend Win 10 to friends who want to take advantage of the free upgrade (yet I will insist they do complete back up images of their Win 7 and 8 systems first!). I did a clean install of the original Win 10 preview and have since been allowing incremental updates as they are offered and never lost any files, cookies, etc. Internal and external drive letters get reassigned during some updates, but nothing has been lost. Nevertheless I have been backing up files every day just in case.


#10

This is a great writeup.

I’ve had a ton of problems with Windows 10. Lots of crashing, slowness, issues, and the PC Settings screen is just awful. The only way to find anything is to search. Maybe that was their goal.

I’m using a Surface Pro 3 as well as a VM, and have had a lot of varying issues in both. The onscreen keyboard constantly comes up in handwriting mode for some reason, despite constantly switching it back to normal.

My biggest problems have been with Windows Update - it’ll crap itself all the time and refuse to update, give me errors.


#11

Yes Win 10 builds are not even close to the stability (not necessarily polish) of previous versions of Windows at this stage of the game. I’ll reserve judgement until final build and encourage all my customers to wait and see how it goes on July 29th.

For now I’m ok with being the Guinea pig, but it certainly does not look good at this stage of the game. The quality of build on the newest phone update was like night and day though from the previous build. It went from totally unusable to being my daily driver, although still quite handicapped in many areas. Should be interesting for all us computer guys that help folks with their pc’s. Gonna enjoy my time before it hits the fan.


#12

Thanks for the plaudit, boss (actually I’m not sure whether you can have just one plaudit; the OED only defines “plaudits” - but I digress).

Following an idea about the processor NX setting, inspired by a commenter on my similar MS Community Windows Insider Program post, I checked for HP 8540w BIOS updates, and found one for 2014. So I upgraded the BIOS, and checked that all the switches that looked relevant were set. There is still no explicit NX setting, but DEP and virtualisation are set. The NX mode has been around for a while, so should obviously exist on a Core i7, but I checked with SysInternals’ Coreinfo anyway. Then I reinstalled Windows 10, and everything worked fine - for about an hour. Alas, after that all-too-brief period of elation, the OS gradually collapsed around my ears again - SNAFU. The performance just gets gradually worse, and doesn’t recover much on reboot, probably because the file system is being corrupted, if the frequency of automatic CHKDSK runs and error corrections is anything to go by.

I would have thought that the operating system would have checked for NX operation if it required it, and refused to install if it wasn’t right; on the other hand, I would also have thought that the setting could be changed programmatically during boot-up if necessary, but I know very little about processor switches. Above all, I would have thought that the OS would either work or not work, not run OK initially and then decay.

Your average user of a Windows 7 system who has accepted the outrageous invitation to “reserve” an upgrade to Windows 10 is going to be blissfully unaware of all this until 29 July, when he/she is going to get one hell of a shock, first because of the differences in the UI, and then maybe when this apparent freebie brings with it all sorts of associated costs in the form of nasty problems. I predict a lot of geeks consoling a lot of distraught family members, for a start.

I’m removing my “reservation” update, as per the boss’s instructions, and waiting this one out. I’ll try the next build ISO when it’s made available, but I’m keeping my old W7 installation. Every time I go back to it I’m reminded of just how good it is by comparison. It’s just - smooth.


#13

Our official recommendation is that everybody should hold off from upgrading until about 3-6 months after the release date. Simply too many bugs and issues for our liking at this point.

I’ve used almost every version of Windows while in the beta or RC stages, and this is by far the least stable version that I’ve used. I used Vista without any serious issues from the time the very first beta release hit MSDN. Lots of annoyances, though, which is one of the reasons people hated it so much, despite the fact that Vista was really a great OS that introduced a ton of much-needed enhancements. And everybody loves Windows 7 despite the fact that it’s just a bugfix and polished UI version of Vista.

Windows 10 is going to be their next Vista, unless they have some miraculous new build that fixes everything. But that seems unlikely.


#14

Interestingly enough…

I went around to all of my desktop PC’s this morning and turned them off, both to save electricity and to save on the cooling bill. (I don’t sleep my desktops, since I remote in to them a lot.)

Amusingly enough, my Windows 8 PC refused to turn off. When I clicked the “Shut Down” button, it acted like I hadn’t clicked anything. Twice. So I opened up a command prompt and issued the “shutdown -s” command.

Windows responded with “A shutdown is already in progress.”

o.O

I finally pressed the power button on top of the machine. That hibernates, rather than doing a full shutdown, but I was already late for work.

So yeah. not entirely trouble free.


#15

Using Windows 8 as a benchmark, almost anything is great :smile:


#16

My 10130 build is on a several years old AMD Athlon II with 8 gigs ram. The few problems I noticed are rare hangups, but they do happen; solitaire hangs up frequently; solitaire settings to not keep from one game to the next; and Office 2016 Outlook is not the best, either. I make rules, then in the next batch of emails more junk mail is there, I make a new rule, but this time it is xxxx(1) or xxx(2) depending on how many times I make the same rule. Why don’t the rules work? Other than that, I am pleased with the build. It recognized all my hardware, even a really old video input card I forgot to remove - left over from Windows 98/XP.


#17

I was using the build 10074 for a month with no trouble. I had it installed in a partition of my hard drive (I am running Windows 7). When I tried to update to build 10130, my computer froze, could not boot at all and I was getting the “preparing automatic repair” sign, but nothing happened. I eventually gve up and restored to an image I had backed up before installing Windows 10. My advice (I’m not an expert), don’t install Windows 10 for at least 3 months after the final copy arrives.


#18

Yes, I’m going to give folks the same advice - wait until 2016.

Having said that… my home-office PC will get the new release as soon as it’s up, and my gaming desktop will probably also get it right away. That way I can learn the new stuff right away and be able to help the folks who are having trouble.


#19

WOW! If I had had your problems with any of the 5 different computers (self built ASUS, AVA built MSI, and various HPs) I would have given up and waited. I have not tried in any multi-boot configurations however. I run VMware Workstation on one with Linux Mint LTS, Office on all but one, Firefox, Chrome, and IE. I run Acrobat on a couple, Stardock customizations on all, BitDefender free and Norton Security on some, Skype, Teamviewer 9, Ninite, and other assorted utilities and programs.

I am 75 years old and knowledgable, but not really expert in the current technology sense. Therefore, I can say that I am really surprised at the problems you are having. I have had none since the first Insider Preview. If it were me, I would start again. Install your separate programs one every few days and thoroughly check. I am willing to bet that you will find a program that is causing your problem. Yes MS, some unique hardware, or the particular program developer could be at fault. Hopefully the metrics followers will know what the problems are and fix them.

I and others I know personally find 10 to be faster in its pre-release state than 7. Yes, there had been problems with FF and Chrome a couple of months ago, but not now. I do not like the organization of 10’s menu, but Start10 or Start8 from Stardock for $5 fixes that nicely. As I have struggled with learning the new layout of things, I have gotten great support from HowToGeek. I am amazed at the depth of sophistication that 10 offers and really surprised by (and a bit scared by) your experience.

It may be mean to say, but I am glad that all this has happened to you but not to me or my friends. I hope that you, MS, your hardware vendors, and software vendors can get this working for you.
Albert


#20

Build 10130 Works for me, No problems.
It is installed on a Dell Inspiron 530s running with a E6600 processor , 4 gigs of Ram , 2 Terabytes of Drive space split between 2 drives.
Multi-Boot setup, Build 10130 Shares a Drive with Vista (x86), Win 7 (64bit), Win8.1 Enterprise(64bit), Ubuntu 14.04.2LTS (64bit).
The drives are Really Crowded for Space (almost full) and Build 10130 Boots up FAST, No problems with sign-in screen.
I do agree though that the update throws out an error code while trying to download a duplicate driver, That said, I am looking forward to a Few more Refinements.
Ric