Windows 10 - DNS stopped working


#1

My Win10 laptop suddenly can’t reach any websites anymore.
There seems to be an issue with the DNS queries.
However, a command line ping to an external IP address (e.g. 1.1.1.1) works perfectly fine. That is telling me that I do have a connection to the web and that my hardware is intact.

The WiFi router is not the problem - my wife’s laptop is showing no issues using the same WiFi router. (Also, my laptop shows the same symptoms when I use a cellphone as WiFi hotspot instead.)

I looked online for newer drivers for the WLAN card - none found. Driver appears to be up to date.
I tried ipconfig /flushdns and arp -d * … didn’t help.
Changing to manual entries for the DNS servers instead of automatically getting them didn’t work either.

“We need to go deeper…”
Running WireShark while doing a “ping some.domain.com” at the command line, I don’t see any DNS protocol query package going out.

Does anyone have any ideas what could prevent the DNS queries from being sent out?
(I ran scans with AVG and MalwareBytes. Number of suspicious items: Zero.)

(P.S.: Corrected a typo… I had /dnsflush instead of /flushdns)


#2
  1. Check if the network interface has a DNS IP address in Network Control Panel aka. ncpa.cpl.

  2. Clear DNS cache:

 ipconfig /flushdns
  1. Restart DNS cache service with this command in Command Prompt as administrator:
sc stop "Dnscache"
sc start "Dnscache"

#3

Thanks for the reply.
I had already tried the /flushdns option.
Didn’t help in my case.

However, I have found a solution.
Good old Mr. Google delivered one search result that suggested disabling non-Microsoft services via msconfig. I disabled 5 that didn’t seem essential and - voila - it worked.