Windows 10 clock won't stay correct


#1

Been straining my brain for the last 2 days. I have a triple boot system, Linux, Win 7, & Win 10. I was able to turn off UTC in Linux (UTC=No), and that corrected the time problem with Windows 7, but no matter what I do in Win 10, the clock boots 5 hours SLOWER (that tells me it’s not UTC related, it would be 5 hours FASTER). In each set, I made sure the BIOS was showing the correct time (it was). If I only go between Win 7 & Win 10, the clocks are correct. ALSO, Win 10 is NOT syncing with either NIST or Windows time servers. I have to manually correct the time in Win 10. I would appreciate any suggestions, other than what’s already on Google (I’ve done them all). TIA.


#2

It looks like you are not the only one who has this issue. Does your manual correction work? Are time & date settings in Win7 and Win10 same?


#3

The time settings WERE correct when I posted, but I went to Win 7 FROM Win 10, and the Win 7 clock is now 5 hours fast. I can’t win for losing. EDIT: I just went back to Win 10 from Win 7, clock is 5 hours early again. Edit, again: I just went from Linux to Win 10, time was correct. Went from Win 10 to Win 7, Win 7 time is 5 hours fast. Switched back to 10, after verifying BIOS clock is correct, and Win 10 clock is back to 5 hours slow. Booted to Linux. Clock correct. Then booted to Win 7, clock CORRECT. Then went to Win 10, clock is WRONG. From Linux to either of the Win OS’, clock works correctly. Problem is between Win 7 & Win 10.


#4

You might take a look at this!


#5

I did that.Linux UTC is OFF (on local time). When I go back to Windows (either version), the clock is now correct. It’s when I switch between 7 & 10 that the clocks get out of sync. The BIOS clock stays correct.


#6

Solved my problem. This is MS’ fault. MS put a registry key in to use UTC. ( [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation] RealTimeIsUniversal should be a dword with a value of 1. ). It was NOT working. I changed Linux ( UTC=No ), and had to change the MS key value to 0 (ZERO), not 1 (ONE). All 3 OS’ are now showing correct times. I sure do wish I could bill MS for my time to fix this. BTW, that Registry fix has to be done in both 7 & 10.