Wake on Lan doesn't work


#1

HI

I have a problem with my workplace computer, I work at t-shirt printing company as printing tehnician or whatever it’s called, (I don’t speak english nativlly so I don’t know how to translate it) bassically I do whatever is needed to be printed on a t-shirt on some vector program like illustrator or corel.

Anyway recently I wanted to improve my work performance by working from home, we have a lot of orders, and currently I am the only worker for that specific job. So I can’t make all the orders meet the deadlines, and to that purpose I thought I could finish up at home what I couldn’t finish at work.

I set-up the wake on lan in BIOS I enable Wake on Lan feature, as well as in network driver settings all according to this articles:

I have a TeamViewer so I set up the router to forward all the trafic coming through port 9 to a PC with a static IP adress 192.168.8.50 (I make sure it’s static, and I make sure port 9 is opened and accesible), than I setup teamwiever build-in wake on lan feature to wake using public adress which was I don’t know something like 83.227.1.5. (checked that by simply google search ‘what is my IP’), I also set up the port to 9.

than just to check out I shut down my PC and try to wake it up through my smartphone which was by that time connected to wi-fi network of the same router. It worked.

I was happy I could finnally continue working even if I am not phisically at my workplace, but when I come home I try to wake up the computer using teamviewer I pressed wake up button, and waited…waited…waited, for about 30 minutes and nothing happened. I tried again, and again, and nothing happens.

Next day I go to work first thing that comes to my mind is to check if my Public adress has changed somehow, router was turned on, we never turn off the router, I checked by google search ‘what is my IP’ and I found that the public IP didn’t change (I took note day before just in case). So again using my smartphone connected to a company’s wi-fi I try to turn on the PC, and again it worked. I thought maybe there is something wrong with teamviewer that I use at home, so when I come home I tried waking up the PC by using my smartphone, the same one I used at work with the same TeamViewer app I used there. Again as expected it didn’t work., I tried downloading other wake-on-lan apps, they waked up my PC when I was connected to that router through wi-fi, but when at home, they again didn’t.

Than I assume it’s either the ISP blocking it or something on the internet. I have the same ISP at home and at work (Tele2), I don’t think it’s them or the internet because I tried switching to DATA connection on my smartphone which was using a different ISP (A1 (formally VIPnet)) and It worked, but when I came home, again it doesn’t work.

During 5 days of my attempts to track down and fix the problem the public IP never changed, unless it changed the moment I went home and changed back the moment I return next day ( which is redicculus).

The only explanation remaining is that I need to be in phisicall proximity of the computer that I try to wake up, but in that case really what’s the use of wake-on-lan if you need to stay in 10 m radius of the target computer?, I could just press the ******* button.

I don’t know what I did wrong, but if there is something, please help me find it, because I am running out of possible causes to the problem.

Thanks in advance
Best Regards


#2

I don’t believe you need port forwarding with TeamViewer, that is one of the nice things about it, there should be no router changes needed.

As to the wake-on-LAN issue, from what I know the wake on LAN isn’t always reliable. Instead I would check the BIOS/UEFI to see if it has any settings that would automatically power the computer on at a certain time. Failing that, I would just leave the computer on.

With wake on LAN it may be that in order for it to work you have to be on the same network, and to do that it may be that you would need to connect to the network through a VPN.


#3

Well according to TeamViewer manual - chapter 5 section 3 (Wake-on-LAN via a public address) you have to set up the router for port forwarding usually port 9.

The Team Viewer has to be running on the target PC in order to be able to access it. Team Viewer or any other program for that matter can’t run on a PC that is powered down, therefore Team Viewer sends a package (magic packet - as it is called) hopefully the router will forward it to computer and power it up. So when it comes to Wake-on-Lan the only difference beetween Team Viewer and other Wake-on-Lan apps is that Team Viewer has an account so when inputing public adress on target computer all devices that are loged to same account gat this information and you don’t have to memorize the MAC adress of the target computer, instead Team Viewer has all the information it needs to wake up the target computer. Also nobody can power up your computer without your account information which is also a huge difference.

I checked the BIOS settings there are no such options for scheduled start up.

Like I said what’s the use of WoL if you have to be in 10 m radius from the target computer, which is exactlly what it means by being connected to the same network, as for VPN that is one thing I didn’t test, but I would like some info on that, how to connect to the network through VPN?

Thank you


#4

I was referring to general TeamViewer use, you are probably right that the port forwarding would be necessary if you hope to use the wake on LAN.

That would probably need to be another appliance setup and maintained by your organization. I’ve used them a lot but have never set one up, but basically how they work is when you connect to the VPN it sets you up with an internal IP address, so that your remote device would appear to be locally connected on the network. So the theory is if you could set that up you wouldn’t need the port forwarding.