Virtualbox's Seamless mode + VMware's Unity mode glitch – where to look for solutions?


#1

Hi,

I am experiencing a glitch when using one particular software on either Virtualbox’s Seamless mode or VMware’s Unity mode. I intend to use either of these for playing online poker and if I have only the poker client open, everything works fine as intended. However, I also need to use additional software that aids me while playing – a tracking tool that collects data from played hands and generates statistical information in the form of tables that are forced on top of poker tables next to each player. If I open the software, immediately when the tables with statistics appear, there also appears a rectangular gray box around the poker table, which has something to do with the guest desktop because I can see the guest desktop’s icons in the gray area if I move it around.

I’ve tried both VirtualBox and VMware and the glitch is the same. I really need to fix this but don’t know how to approach it. VirtualBox’s Seamless mdoe has major issues when used on Windows 10 that are similar to my glitch just more severe and they have not prioritised solving those issues for several years now, so I figured that asking on their forums about this would not be worth it. VMware on the other hand offers paid support for something like 55$ per 1 problem. That feels like the only route to take currently but I was hoping that maybe someone here has a better idea about what I should do. Perhaps there is a quick fix to try or maybe asking VMware is not likely to result in a solution anyway so I sohuld look elsewhere and save money instead of paying for expensive support for no reason.

I am running Windows 8.1 on the virtual machines. Here’s a screenshot of the glitch:

Any help whatsoever appreciated.


#2

Interesting usage of Virtual Machines! :crazy_face:

In my PC, Windows 10 in VirutalBox seamless mode works well with 2 GB RAM. Check these this:

  • Did you allocate enough resources (e.g. CPU, RAM, Video memory, Disk space etc.)?
  • Check if any background process takes more resource than needed (both in host and guest).
  • Check if VirutalBox driver (VBoxDrv.sys) is installed in host machine. As well as the VirtualBox Guest Additions installed in guest OS.
  • And last million $$ suggestion, update drivers.

#3

I may have explained the issue a bit chaotically. Both the host and guest OS is Windows 8.1. I mentioned Windows 10 issues only to illustrate why I found VirtualBox forums to probably not be worth the time. Many people have issues with seamless mode, me included, but I switched away from windows 10 on the guest to 8.1 and now it works fine except for when I use that particular statistics-collecting software.

I did check for the driver and it is installed in the host machine, as are Guest Additions.

I have allocated 10+ GB of RAM to the virtual machine, which should be overkill, also 4 CPUs, which should also be overkill. 256MB Video Memory with two monitors.

Drivers are up to date. The problem should be related to that specific software because all works just fine if I have everything else open except that.