Update 1903 night light feature


#1

Hello Guy’s , I use my laptop on my 50" Tv to watch movies and other stuff on my laptop most of the time, and all was ok, Till i done the windows 10 1903 update, Now when i connect my Tv to my laptop the screen slowly dims to about 50% brightness all by itself ?. and i checked the laptop and is on full brightness, So checked the Tv , nothing wrong when i change to cable on Tv it goes back to normal brightness, then i change to laptop on HDMI , and after a few seconds it starts dimming again ?. I was told the 1903 for windows 10 pro had a night light feature and when i checked this was off , ?. so i switched it on and then off again , and nothing still the same ?. any idea guy’s ?.


#2

Night light only shifts the color spectrum, taking the blue out of the screen (i.e. the “sunlight”). That wouldn’t be causing the issue here, at least as far as I’ve known – I’m not on 1903, so I’m not sure if they’ve updated it to also adjust brightness.

Are you sure this didn’t happen prior to 1903? This sounds more like a function of the TV itself protecting against screen burn, with the TV logic perhaps seeing that much of the screen (PC desktop) is remaining static, thus dimming it to protect (or slow) against burn. Have you checked all the TV settings submenus to see if there’s some sort of dynamic/auto brightness or screen-protect setting?

Try rebooting into Windows safe mode – does it still dim? If not, then it must be some third-party program that’s causing it.

There’s also the monitor color profile Windows uses, which can be changed to digitally alter a monitor’s “brightness” – not the actual/technical brightness of the monitor, but rather, applying a gradient overlay to the Windows screen output that makes it appear dimmer. Perhaps something is adjusting this profile dynamically.

It may also be GPU related. Have you checked your video card’s settings, like the Nvidia settings panel if you have an Nvidia? After that, you can try going into Device Manager, find your video card, right-click and select “Uninstall device”. It will remove the current GPU driver (which can be easily reinstalled on next boot) and automatically use the base Windows driver/GPU. Before you reboot (since the latest GPU driver will likely be automatically reinstalled on reboot), see if the dimming still happens. If it does still happen, then you can at least eliminate the GPU as the source.

Lastly, try this: pause doing anything on the computer and let the TV dim a good amount. Then on the computer, grab a window titlebar with the mouse and swing it around the desktop quickly in a circular motion – does the dimming change at all, perhaps getting brighter?


#3

Hello Coldblackice, thank you for your post, 1, No this didn’t happen prior to 1903 update , 2, I tried adjusting the TV but but the brighter i set the TV, the more misty it gets and when i change the TV back to watch something on cable or ordinary Tv , i have to change all the setting again , I have a samsung 50" led smart Tv , about 15 months old, .3, Tried booting in safe mode , same thing happens, 4, It doesn’t make any difference if i’m running on battery or plugged in , 5, plus tried to update graphics drivers, no joy,6, and in display setting i made sure hd was turned on , and tried with it off , no joy ?. 7, tried thr title bar swirl in circular motion . No joy.

So , i reverted back to 1809 update , and all is fine ???,
any idea what’s happening .


#4

Hi clunck, so I’m 95% of what the problem is now: Windows 10 1903 has major issues with the night-light feature, interfering with color profiles, gamma settings, etc. So it’s like a 1903 malfunction in that it’s staying set despite you disabling it. There may be a way to forcibly deactivate the feature via the registry, but my suggestion would be to stay off 1903 for now, as it sounds like it’s full of issues and headaches… per the usual for Windows 10 updates :roll_eyes: