[Solved] Help restoring Virtualbox USB access


#1

Booted from a USB using this guide:

via

VBoxManage internalcommands createrawvmdk -filename C:\usb.vmdk -rawdisk \.\PhysicalDrive #

Then I removed the VM and .vmdk.

Now I am unable to connect any USB device to any VM on that system.
VirtualBox tries to mount devices forever with no luck.


#2
  • What is the host operating system?
  • How did you remove the VM? Just remove or deleted file with it?
  • Did you try to tinker any configuration files? More on this later.

#3
  • Windows 10 1809 64bit
  • Removed the VM and all it’s files.
  • Did not touch any config files.

Thanks for the response, meanwhile I was checking my system again to verify everything and actually solved this.

I’ll write it down in case someone has this problem.
I also got a general error this time:

Device busy with a previous request (0X80070057)

This led to some articles on Troubleshooting Windows driver issues.

They all mention removing UpperFilters value in the key:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{36FC9E60-C465-11CF-8056-444553540000}

But before I deleted it I noticed the data: USBPcap.
Some reported deleting the key is not working for this case, you might need to uninstall USBPcap.

USBPcap is a driver installed with Wireshark.
You can’t have it if you want VirtualBox USB pass-through .
This also affects NoMachine, Roxio and Dell Data Protection Agent.

Interesting part:
That bug dates 2012, was almost fixed in 2017, but it wasn’t:
https://www.virtualbox.org/pipermail/vbox-dev/2017-July/014633.html


#4

Please mark this thread as solved.