Software from PPA


#1

Hi all. I am trying to install Zoneminder on Ubuntu Linux system.
I followed the instructions from the following page

but I still cannot see the app in Ubuntus’ gui program.

All the stages I followed seem to have the correct response.
I even tried installing the ppa:graphics-drivers/ppa for Nvidia X but couldn’t get this to work either.

Any clues as to where I’m going wrong?

John


#2

Here is the full detailed link: https://launchpad.net/~iconnor/+archive/ubuntu/zoneminder

You need two commands to run as root:

sudo add-apt-repository ppa:iconnor/zoneminder
sudo apt-get update

#3

I have already tried that from the terminal program but I will try again tomorrow.
Thank you for your reply.

John


#4

I have already tried that but gave it a go again.
I entered the 2 lines you mentioned via a terminal program.
I then checked software & updates/other software and 2 new lines appeared as expected.
The problem is when I check the Ubuntu software program, Zoneminder doesn’t show anywhere.
Not sure where to go now.

John


#5
  • it depends on what version of Ubuntu you have. I will work of the assumption you are using the latest Ubuntu LTS = 18.04 aka Bionic Beaver.

  • the Zoneminder PPA is not maintained by Zoneminder but instead a 3rd-party. This 3rd-party has not made an update to the PPA since May of 2017. The latest version of Zoneminder was October 2018.

  • because the PPA has not been updated since May 2017 it means that it has never built a package for 18.04 or 18.10 and thus is basically worthless for those versions of Ubuntu.

  • the latest version of Zoneminder in the PPA is 1.30.4 and the same version is available in the normal Ubuntu repositories so you can just install that version as they are the same.

    • sudo apt install zoneminder
    • might want to remove the PPA though
  • If you want the latest version of Zoneminder then you will have to go through the Debian install steps, this might work or might not. Or you can compile it from source which is certainly a lot more effort to do.

You don’t need to use the PPA unless you absolutely want to use the Beta version of the drivers.

If you just want the latest proprietary drivers then just use:

sudo ubuntu-drivers autoinstall

@Biswa, you should recommend apt not apt-get, I wrote an article about that here on HTG.


#6

Amazing :heart_eyes: I don’t know you are HTG writer. I’ve not seen any current articles (last one was Aug’16) written by you. Are your articles hidden?


#7

@MichaelTunnell is a Linux expert and is our Linux guru here on HTG.

Since Michael won’t blow his own horn - I’ll do it for him here by posting a link to his website.

https://michaeltunnell.com/


#8

I am a writer but I haven’t been writing for anyone for quite a while due to other ventures and other issues. I hope to be returning to writing as soon as possible . . . I have even submitted like a dozen potential article ideas to HTG so :crossed_fingers: :smiley:

I am currently working on my YouTube and Podcasting Empire* via TuxDigital.com if you’d like to check that out.

  • note - empire in the sense of not even remotely an empire. :smiley:

Thank you very much . . . I don’t know if I would call myself an expert or guru but I humbly accept you doing so. :smiley: