Seagate Backup Plus Slim 2TB External HDD has varying read/write speeds on different computers


#1

I have a Seagate Backup Plus Slim 2TB Portable External Hard Drive. I used this hard drive for around 2 years with no problems. Then one fine day, every media file on the hard drive would stutter during playback for some reason. I was convinced that the problem was with the HDD, so I had it replaced. I just got my replaced HDD yesterday, and unfortunately it is facing the same problem.

I did some digging. I ran Crystal Disk Mark test on the Seagate HDD on:

  • My Laptop
  • 2 Desktops

The problem seems to occur only when I’m using it with my Laptop. And it’s really clear with Crystal Disk Mark test results too. I’m completely baffled and have no clue as to why something like this would happen.

I copied a 8.6 GB file from the PC (Internal HDD) to the Seagate HDD and it absolutely crushed it with a constant speed of around 130 MB/s.

When I copied a 10.9 GB file from the Laptop (Internal HDD) to the Seagate HDD, it would sometimes dip down to 355 KB/s and for the rest; vary between 20 MB/s to 50 MB/s.

I have tried all the ports on my laptop and the issue persists. I tried copying the 10.9 GB file from my Laptop to a different external HDD, and it was working fine.

Also the media playback (of files on Seagate HDD) won’t stutter at all on PC, while I cant go 15 seconds without the playback stuttering on my Laptop.

This is very strange, and I have conclued that the Laptop specifically isn’t playing nice with the Seagate HDD. This seems really unscientific to say the least, specially since my laptop is the more capable machine on paper.

Any clues?

Crystal Disk Mark Test Results on Laptop
image

Copying 10.9 GB file from Laptop to Seagate HDD
iihrd

=====================

Crystal Disk Mark Test Results on PC
p5lI3

Crystal Disk Mark Test Results on another PC
15NrT

Copying 8.6 GB file from PC to Seagate HDD
VcK6A


#2

Dude, your animated screenshots are slick. Gotta give you props for that.

Are those USB port types the same? If your laptop has 2.0 ports the speed would make sense as the max should be about 60MB/s. Where as 3.0 ports should have a max of about 640MB/s.

Otherwise have you checked the laptop to make sure it has the latest drivers (including BIOS/UEFI)?

Try running system file checker just to make sure all the Windows system files are intact:


#3

Thank you for the compliment. :grinning:

1 x USB 3.1 TYPE C port(s)
3 x USB 3.0 port(s)

That’s what the specs sheet says.

I tried updating the two drivers marked in red in the screenshot below, please let me know if I should check any other driver.
Both tell me that ‘The best drivers for your device are already installed.
I will check every other driver using the full Simple Driver Installer utility.

I absolutely dread updating BIOS/UEFI, and simply don’t want down that road.
I think I read it on howtogeek that BIOS/UEFI should be left as is, something along the lines of “don’t update if its not broken”.

I will run the SFC scan, that’s a good idea. My laptop has had issues (according to sfc scan) before reinstalling windows.


#4

It makes no sense that there would be a SCSI disk driver for the drive, a USB disk drive should show as USB not SCSI.

If you installed a driver or utility software from Seagate, uninstall them and see if Windows installs normal USB drivers when you plug in the drive.

In general I never install software for USB storage devices since USB storage is a well defined standard and Windows includes good drivers that follow the standard.


#5

Thanks for the reply Paul.
I agree, that ‘SCSI’ had me worried the most. I don’t know much about SCSI, but I do know it isn’t normal for it being even mentioned in device manager.

The thing is, I didn’t install any utility/software/driver provided by seagate ever. It was handled by windows, just like any other external HDD.

I have observed something new, this erratic copying speed; it appears to be happening to some pen drives too. I just used this blazing fast 3.0 kingston DTSWIVL 32gb to install Windows on a PC this evening.

Rufus prepared the installation media extremely fast. Windows installed extremely fast too.

But on my laptop the same pen drive gives me an average of 3 MB/s; dropping to some meager kilobytes every now and then.

I have another pen drive which used to behave properly, good speeds and all and then one fine day it just didn’t anymore (just like the Seagate HDD).

I just don’t understand, how can some devices work so well with a usb port, and others so horribly with the same usb port.


#6

Should I raise a complaint of faulty usb ports with the manufacturer?
The device is under warranty. It’s going to be extremely difficult to prove this whole thing to them though.


#7

Who is the laptop manufacturer? Some companies, like Dell for example, make it extremely easy to update the BIOS/UEFI.


#8

ASUS
It’ s an ROG GL502VM FY230T


#9

Actually, the new standard is UAS, or USB Attached SCSI. So there should be a SCSI driver for the drive. UAS about doubles the speed of the interface, compared to the standard USB storage profile. (This is a good thing, because the standard profile only is about half as fast as the bus is supposed to support.)

My guess is that the USB 3.0 ports are being fed internally through a hub, and I’ve had very mixed results using hubs with external hard drives.

One thing you can try is using an adapter cable and connecting to the USB C port. Since that’s a 3.1 port, it should not only be faster, but it should be on its own root hub, separated from the 3x USB 3.0 ports.


#10

Seems like its been a while since they released an update. Can you run msinfo32 and see if your version matches up with the latest one on their site?

image


#11

But that doesn’t solve the real issue. I am going to use the USB type A ports almost all the time.


#12

So I ran SFC scan (in safe mode) and it says everything’s fine.
I also ran the DISM command, just to double check. That was fine too.

I also updated whatever drivers needed it with Snappy Driver Installer. It tells me now that I have all the latest drivers.

Seagate HDD stays super slow.

Also the Seagate HDD and these pen drives that I’m talking about, they still copy with extremely fast speeds when the direction of transfer is from the Pen Drive 🡺 Laptops Internal HDD.


#13

BIOS version is 305, but the date is different than the one on the website.

BISO%20Version


#14

When you right-click that Seagate drive in the device manager and go to properties, do you have a Policies tab?


#15

Seagate HDD

SONY

SAMSUNG

Pen Drives suffering from the same problem

I don’t know about the pen drives, but the Seagate HDD has Enable write caching on the device CHECKED, even though its grayed out.

What next?


#16

Thanks for the information, I’d forgotten about that change from 6 years ago because this is the first time I’ve seen it shown in device manager. From what I’ve read Microsoft has been providing the drivers since 2012 but still I’ve never seen it listed and I wonder why Seagate is providing a custom driver.



#17

I would say try the Better performance option on that drive. That checked box might have been a previous setting and isn’t actually enabled, but I assume once you select the Better performance option those grayed out options will be available.


#18

@larrylmitchell

Referring the Faulty battery/Improper shutdowns case here:

I did reinstall windows in an attempt to rule out its role in these improper shutdowns.
It was not a fresh reinstall. I used the Reset This PC option from the settings which is supposed to be close enough to a fresh reinstall.

I then purchased a new battery and the issue was resolved.
And surprisingly the Seagate HDD is working fine now!

I have no clue what happened here.