Samsung S7 security invisible


#1

My new Samsung Galaxy S7 won’t wifi to my Asus RT-N16 router. The network shows up in the list as unsecured when it is actually WPA2-Personal secured.

I tried the S7 on another router and it worked and saw the security.
Other phones and laptops connect to the Asus and see the security lock.

I cannot find a way to manually enter WPA2 an the S7 settings.
S7 “forget” does not remove the network.
Manually adding a network doesn’t yield anything in the wifi available list, I think because the name is the same. Still shows the “open” network.

Is there a way to force the S7 security?

Is there an app?

Thanks
Andy


#2

Did you already try restarting the phone? Have you checked for any updates on the phone?


#3

Hi Larry. I went through all that stuff, but the problem was a bad setting in my router. Its an Asus RT-N16 w/ custom software. The WEP/WPA2 setting allowed the WEP to still be active, which prevented the phone from seeing the active WPA2. Once that WEP feature was disabled the phone could see the network security and hooked up fine.
Underlying problem was having only a partial knowledge of router settings.