Linux mint installation issues


#1

Tryinv yo install linux mint but the usb will only load to grub menu. Not sure what im doing wrong. Used rufus to burn a gpt image. Turned off secure boot. Turned on f12. My machine is an acer aspire switch 10 with 1.3ghz atom. 2gb ram. And 32gb hdd. It runs win10 no problem Any help would be aprrciated.


#2

First, use dd mode in Rufus to make Linux distros bootable. Second, 32 GB hard drive isn’t enough for dual booting, Windows will eat up maximum of it. Third, GPT isn’t an ‘image’, it’s called GUID Partition Table.


#3

Was going to boot linux as a single boot. So should i burn iso as gpt or mbr in rufus. And thanks for getting me know bout burning in dd mode


#4

just use Etcher to burn the ISO to USB as it is the most straight-forward way to do it and you dont have to deal with any kind of configuration stuff.

You say that you want to do a “single boot”, so are you looking to completely delete and replace Windows with Linux Mint? If so, you don’t really have to deal with any partitioning as the Linux Mint installer will auto-delete and install Mint for you.


#5

Ive done that but i only get as far as the grub menu.


#6

Did you install it or it just stuck in boot menu from USB?


#7

No idea to be honest. Im new to linux/ubunti. Justwant an OS that speeds my system up. Win10 is quite laggy


#8

did you use Etcher or Rufus?

if you are not sure if you installed it then you haven’t because that process takes about 15 minutes and you have to manually initiate it.


#9

I used rufus to burn. Using gpt. Just about to try etcher


#10

Etcher will make this much easier.


#11

Tried etcher. Now i just get no bootable drive. The usb does not show in f12 either.


#12

This is driving me nuts. I followed all the advice and install guides but nothing seems to work. I have even trid linux mint mate and ubunti mate 18.10.


#13

Windows 10 has a lock for booting other systems “for security” but really it is to make this as difficult as possible.

Have you been able to get into your system bios/uefi with F2/F8 (or)F10 (depends on your manufacturer)


#14

Yes. Disabled secure boot. Enabled f12 boot. Should i load a efi/uefi file into the bios. And what one should i upload thrre if needed


#15

OK, here is the detailed instruction using Rufus.

  1. Download latest version of Rufus. It is important to be it latest. If Windows Firewall blocks Rufus allow it (don’t requires normally).
  2. Start Rufus as administrator (if requires). It may download some files (not so important in our context).
  3. Plug in the USB driver > choose the 64bit ISO > Partition Scheme: GPT > Target System: UEFI > File System: NTFS > Click Start. The window will be something like this:

  1. After clicking the ‘Start’ button, there will be a popup like this:

Rufus mode popup

:warning: ALWAYS choose the DD Image Mode for Linux distributions. Press OK. :warning:

  1. Wait some time to write. Reboot PC. Press F12 while rebooting. There will be option like “UEFI: Generic Mass Storage” or something similar.

I have tried it now with my SD card to USB adapter.


#16

Trying that now. Just a little confused that most sites said burn as fat32. Using rufus 3.5. Heres hoping i get it to work. Thanks for all your help. 3


#17

Works fine on my main laptop. A sony vaio. But it still wont show up on my 2 in 1 acer switch 10. Does it make a difference that the internal hdd is blank. I wiped the drive with gparted and made it an msdos partition.


#18

OK here comes the tricky part, “THE UEFI”. You have to check if UEFI is enabled in PC BIOS menu (press DEL or F2 during boot). If you want to install it with normal legacy BIOS mode just change the Partition Scheme: MBR and Target System: BIOS in that first screenshot.

At the time of booting from external USB drive, the internal hard drive (HDD) is not important.


#19

Ok thanks. Ill give it a try tomorrow. No patiece left tonite.