Linux does not detect the Wireless Card


#1

Hi there,
I have a laptop wich I used with Windows, but now I installed Ubuntu 18.04 bionic, the problem is that does not seeams to have a Wireless device detected on the Ubuntu. It detects the bluetooth but no the wireless.
On windows it works fine.
I don’t know exactly the chipset for the card,In Win appears named as Broadcom some thing like that but I am afraid that is not the chipset.
Is not a commercial laptop, is a Ultrabook Intel
I’ve tried some possible solutions, but no changes.

Anyone could help?


#2

Does it appear in ip a command as root?


#3

Open up “Software & Updates” application and click the “Additional Drivers” tab and have it scan to see if detects the network card. If it detects it, select to install the drivers. If it doesn’t see it, you will need to give us some more details on your notebook such ask the model number.


#4

Generally a quick Google search fixes everything. I might be wrong but I guess the problem was due to the hardware being somewhat wrongly implemented.


#5

Find out what chipset this wifi device uses, and google the name of that chipset plus + linux driver + distro you are using.


#6

No, it does not appear. I t only shows up the loopback link.


#7

Thats what I did my friend, and I’ve tried some things with no results.
The problem is how I know the chipset model exactly?


#8

Have you tried any other live distros, especially anything more recently released, to see if it picks up the wireless card? Also, Ubuntu 18.04.2 update is supposedly due out today so you might want to download and try that when it comes out. It’s possible that your wireless chipset is supported in a newer linux kernel. You may also want to try googling the brand name and model of your notebook along with linux wifi driver to see what comes up. I’ve done that with other notebooks I’ve had in the past to see what what wifi chipset that notebook had at the time.


#9

exact model laptop?
what is the make and model of your wireless chip?


#10

Hi, you can refer to this blog
https://help.ubuntu.com/stable/ubuntu-help/net-wireless-troubleshooting-hardware-check.html