Keyboard no longer working Acer Aspire R11 lappy Win 10 home


#1

So one night I was working away editing and annotating a document. Saved my work, put the puter to sleep and the next day when I lift the lid, the log in lock screen screen appears and nothing on the keyboard works. Mouse pad still works.

If I flip the lid and put it into tablet mode, the onscreen keyboard works fine.

I’ve searched some tech forums for assistance - filter keys is “off”, I’ve deleted the PS2 keyboard driver and rebooted, but still no keyboard functionality. I’ve checked for updated drivers, but it’s the latest. I’ve run troubleshooter, it says all is fine.

If I roll back to a previous update, won’t the issue just return due to Windows automatically spamming updates?

Any advice would be appreciated.

Thanks


#2

First you need to establish whether this is a mechanical or a software problem. Have you tried booting to the BIOS setup or to a Live Linux USB drive?


#3

Thanks for your response!.

No I haven’t booted up to the BIOS set up, and there’s no Linux in my non computerliterate world…

Booting up to the BIOS set up requires holding a key down during start up right? If the keyboard isn’t functional I’m not sure how I’d achieve that.
??


#4

The point of the exercise is to figure out whether the problem is your keyboard or the Windows drivers.

If the keyboard is working during the POST stage and lets you into the BIOS setup, then you have a software problem in Windows. If the keyboard does not work in this phase, then the problem is probably your keyboard, and updating (or downgrading) Windows isn’t going to fix anything.


#5

Rightio, fair enough comment!

So when I hold the F2 key on boot up, the Aspire will boot into a ACER-biased BIOS setup mode. It’s called the “InsydeH2O Setup Utility”. In this mode I get access to arrow, escape, function and return keys which I assume means full keyboard access (I didn’t find anything to type alphanumerics into to test).

Interestingly, just as an aside, having gone into this page and despite having exited without saving any changes (i.e no changes made) subsequent boot up/start ups have slowed right down.

Anyway, looks like it’s a software issue. Appreciate your further advice.

Thanks


#6

Anyone with any further advice?

Looks like I will have to go and pay a tech to deal with this then.


#7

I’ve never seen this happen, so I’m a bit lost. Sorry I can’t be more help on this one.


#8

I stumbled upon an unlikely solution that worked… An acer battery reset. Stuffed if I know why it worked but woohoo, the keyboard came back to life.


#9

Sometimes it’s the simple things.

I’m glad you got it working.