Fed up with Microsoft's stupidity


#1

I have my connection set to Metered. I went to turn off my computer last night and it said “Update and shut down.” I wasn’t even aware that it downloaded updates, but whatever.

But now, I can’t open my start menu, settings, volume control, etc. I have Firefox pinned to the taskbar and that opens fine. Strangely my network icon says no internet, but I’m using that connection to post this. I tried SFC/scannow and it found nothing. I restarted and that didn’t work. I’m going to try safe mode and making another user and chkdsk and re-installing default Windows apps, I’ll let you guys know how that goes.

But my main complaint is, I don’t want Windows to update. I want to only download security updates I select manually, or at least automatically. Is that possible? How do I keep Windows from downloading ANY updates even on a metered connection?

And I heard somewhere that Windows will reserve 7 GB for updates. Is that true? Can I prevent that as well?

I want to control my computer, not wake up one day and let a machine decide for me how my day is going to go (I wasn’t planning on spending all day making my start menu come up, of all things.)

Maybe the writers at How-To Geek can make an article about this. I’m sure a lot of people would benefit.

Thanks!

UPDATE: I restarted again, attempted to go into safe mode by pressing f8 but I guess that doesn’t work anymore because of why…??? But now my start menu opens, and I can open settings, and everything seems okay. I checked and I hadn’t had my connection set to metered, my bad. But still, it still updates sometimes even when it’s definitely on metered, is there a way to prevent that?

Also when I had first got on my PC today, as soon as I moved the mouse the words “Activate windows 10 in settings” or something along those lines were overlayed on the bottom right of my desktop. It went away when I restarted the first time, but the start menu and all still didn’t work then. Still working now though. Is there a way to see if it’s activated and a way to prevent that from happening again?


#2

Open Settings > Update > Advanced Option > tick Defer updates.

To disable update, you can disable the “Windows Update” service from Service Manager (run services.msc). But you know – “Windows 10” and “metered connection” – those two words don’t fit in one sentence. Windows 10 constantly sends user data.


#3

Update defer works for Windows 10 Pro, Enterprise, Education, and Windows 10 S. No good for Win 10 Home.


#4

You can try Stopupdates10. http://greatis.com/blog/stopupdates10
So far seems to work well and simple to use.One problem common to all blocking programs MS will change things and updates will start again.This software can update as MS changes the rules.
Riche


#5

With Windows 10 users lost control of Windows updates. With Home you basically have no control, with Pro you can defer updates up to a month.

There is no ultimate edition, and while you have more control with enterprise edition, you can’t purchase that retail.


#6

Great, sounds like no luck… I have Home.

Thanks for the suggestion Riche, I’ll try that!

I thought I heard somewhere that you could block it with a firewall or something?


#7

Perhaps, but if you’re successful, you may be blocking out security updates too.

A bit on a tangent… my near-term goal is to use as many ‘portable’ apps as possible, load them all into a separate partition… so if I ever have to reinstall Windows from scratch, I can minimize the apps and app customizations I have to do. Wonder if others here have done similar?