Dark Mode in Chrome


#1

I Have searched everywhere and can’t seem to find the answer to this problem. Perhaps there isn’t one, but maybe someone here can help.

I am trying to get the main google search page (not new tab page) in dark mode. I have tried windows 10 dark mode and the force dark mode trick described here. Both only turn the top tabs dark, not the page itself.

Is it not possible, or am I doing something wrong?

Thanks for any help with this. The all white page is killing my eyes.


#2

I use Dark Reader extension (MIT license) both in Chromium and Firefox. Here are the links:

With this, you can also add custom rules.


#3

Thank you for the suggestion. I kind of have that idea on the back burner for now. I really only want the google search page darker and not every web page.

I did try a different extension (Care your Eyes) and it works for google, but I ran into conflicts with other web pages even if I disabled it for those sites. Finally had to get rid of it.

Would really appreciate any other help you might have.


#4

As I said in previous comment, you can add any rule you want. Here is the procedure with Dark Reader. Install the extension > Click on the icon looks like Darth Vader (a black hooded mask) > Click Site list > Choose Invert listed only > Enter the website that you want in dark mode. Here is a sample screenshot in Chromium.

You can also do the opposite in “Not invert listend” section.


#5

Thank you for the instructions. This does seem to work although a couple of my financial websites do not seem to like it and take a very long to load. I have it set to only be dark on google.com, but I guess those sites can still detect it. When I disable dark reader, financial websites respond normally. Same thing happened with the Care Your Eyes extension.

If I could figure out how to search from the search bar and not the address bar on the new tab page, I could just use it with a theme and be done with it. Guess that is not allowed.

Funny - Themes work on new tab page, but not on Google search page. Search works on google search page, but not in the search bar of new tab page. Guess you can’t have everything.


#6

Sorry for late reply, timeline issue!

Can you provide the url of any website that doe not work? Yes, I admit that it may not work in some website. If you have some idea of CSS (Cascading style sheet) there is a “Dev tools” option at bottom-right corner to add custom rules. Otherwise you can open an issue at this link https://github.com/darkreader/darkreader/issues. There are many issues of this same kind. Your issue may also help others and the whole community.

Themes and this type of extensions work in different way. Very complex…


#7

Haven’t found a website that didn’t work, just VERY slow loading. This started happening with enough sites that I just removed dark reader. Will keep trying to find a solution that works for me. Thanks for your help.


#8

if you find anything, please post an update here, I would be interested to know as well