Cannot map network drive in Windows 10


#1

Hello,

I had a home network drive connected to my router mapped successfully to my Surface Pro running Windows 10. I had to reset it because of another issue. Now, I cannot reconnect to the drive.

When mapping the drive, the folder does not show up when I click “Browse” after I select “Map a Drive.” All I see is an icon that says “Network,” which I am unable to click on.

Network discovery is turned on for private networks and my network is set to “private.”

I worked for me when I first got the computer. I have no idea what I’m doing wrong. Any help would be appreciated.

Thanks!


#2

You might take a look at this.


#3

Those are the instructions I followed before and it was successful. Still doing the same steps after I had to reset my PC and now these steps don’t work.

Unfortunately, I don’t see my drive when I click “Browse.” I just see “Network” which is really strange.


#4

Update: I’m getting an error message about the device using an older SMB protocol:

https://imgur.com/GtgIQE8


#5

You can try this.

In a typical home environment, nobody cares if the SMB v1 protocol isn’t secure.

So, just go to the “control panel” -> “program and features” -> “turn windows features on and off”, then put a check mark at as shown below

Image


#6

It worked!!! Thank you SO much. I can’t thank you enough. This has been keeping me up the past three nights driving me up a wall.


#7

Glad I could help you out.


#8

Do keep in mind that SMB 1 is very insecure, has been the entry point for much ransomware, and will never be fixed because it has been obsolete for a very long time. It’s a roughly 30 year old protocol, the safer SMB 2.0 is 12 years old and there have been 4 updates since (latest is 3.1.1 released two years ago).

If your router has a firmware update to a secure version of SMB install the update. If the router does not have an update available it may also have other vulnerabilities and in that case a new router would almost certainly have better performance as well as less vulnerabilities.


#9

Thanks for the info! I just checked for a firmware update and my router says that it is up to date. The router isn’t that old…about four years old or so. Was support for SMB 1 discontinued very recently in an update? I ask because when I reset my PC and reinstalled Windows, it did some updates, and this is when I couldn’t connect to my network drive anymore. When I first got my Surface a year ago, I was able to connect without a problem.

I’m just wondering if there is another issue at play as to why I can’t connect.

Edit: Would installing something like Malware Bytes be enough to keep me secure?

Also, would getting a newer USB drive fix the issue? Again, the drive is about three or four years old.

Thanks again!

Edit again:

Apparently Linksys is not good about offering firmware updates and others have had a similar issue. https://community.linksys.com/t5/Wireless-Routers/Someone-knows-when-SMB2-will-be-enable-on-wrt1900ACS-router/td-p/1271968

I guess it’s time to look for a better router. Currently I have the Linksys 1900ac.


#10

IIRC, it was the last major update from Microsoft that disabled it, but they didn’t discontinue support they just turned it off as you’ve seen. Microsoft finally got sick of hearing news stories about malware and ransomware spreading via an obsolete version of their protocol and decided it was time to turn it off by default.

As to any software being able to protect you, experience says no. New vulnerabilities in SMB 1 are still being found and bad guys are using them to distribute malware and ransomware. Getting a new USB hard drive will have no effect at all, the protocol is in the file server part of the router.

That said, as long as the firewall in the router is blocking all the ports used by SMB, it will only be exploitable once the malware gets in side the LAN. So the risks are lower than most which is why many people are turning it back on for old device compatibility.

Buying a new router every 3 to 4 years has a lot of benefits in terms of both performance and security. If you do buy a new one make sure it has automatic updating of its firmware as all the new good ones do.


#11

SMB 1 was disabled with the 1803 update for Windows 10, I had run into the same issue when using my external hard drive that was connected to my router. I was able to update the firmware on the router to resolve the issue so that I didn’t have to re-enabled SMB 1.