Asus C202S "Battery Not Found" But Works Without Charger


#1

Hi!
My Asus C202S started acting weird intermittently with regards to charging. I’d plug it in until the battery icon read 100%, then sometimes when I’d unplug it, the display would still indicate a full battery, but a warning would come up saying I had 1% left. If I didn’t plug it in again quickly, it’d shut off. Other times I could use it on battery for a few hours.

I tried a second charger which initially seemed to fix the issue, but the same weirdness came back.

Next, I suspected the battery or a battery connection. You see, a spider jumped on my keyboard a while back and I threw the laptop across the room. I found out about “crosh” and did a battery_test. It told me that my battery health was zero.

Next step, I opened it up and looked for a loose connection. I followed a Youtube but didn’t find any loose connections or noticeable internal damage. It’s a pretty tough unit. I pulled out the battery, reinstalled it, then put the unit back together.

After reassembly, it fired up just fine, but my battery icon didn’t appear. I unplugged the charger and it continued to function, but the screen didn’t dim as it usually does when I switch to battery. Running another battery_test resulted in “Battery Not Found.” Even after a reset, the result was “Battery Not Found.”

What have I done? How can I get my battery status restored?
Thank you!


#2

How old is the Chromebook? A lot of batteries only have a one year warranty.

Its possible the hardware is damaged in a way that isn’t visible to the naked eye, the only thing you can do at this point would be to try replacing the battery, which may not be worth it because it could cost half the value of the Chromebook.


#3

Hi Larry. I appreciate you taking time to answer my question. My Chromebook is 2yo, and yes, I have the same cost/benefit concern with replacing the battery.

Here is what I have learned over the past day or so:

  • Within a few hours of putting my Chromebook back together, I unplugged the charger. It shut down almost immediately after I unplugged it and still had no indication for the battery.
  • I reconnected the charger and powered it back up. This time, the battery indicator appeared and indicated a full charge. I unplugged the charger again. This time the unit stayed powered up.
  • I ran the battery_test in crosh. Now, the battery health is ~70%, rather than zero.
  • For almost two days now, I’ve had it on and off the charger. The battery drain looks normal, and the battery health has stayed ~70%.

What I’m thinking is that my Chromebook just got confused. The battery sensing/monitoring needed to be reset and by disconnecting and reconnecting the battery, it did reset. It took a few hours, though.

So far, so good. Fingers crossed. Thanks again for taking the time to respond to my concern.