Application-specific volume not following master volume in Windows 10


#1

I just read this HTG article and was hoping to solve my problem with windows 10.

The article mentions:

An app’s volume level is configured as a percentage of your master volume level. For example, if you set your master volume to 10 and Chrome to 100, Chrome will play at a volume level of 10. If you set your master volume to 10 and Chrome to 50, Chrome will play at a volume level of 5.

That’s how it’s supposed to work, that’s how it has always worked in Windows 7.
My problem is:
I set Master Volume, for example at 5%.
I open a new application (or chrome tab with sound), and it has a volume of its own at 100%, and I have to manually turn down the volume on the application.

Is there a way to cap ANY volume coming out of windows 10? It’s really irritating to know that any moment a very loud sound can come out of the computer.

PC Info:
Dell Inspiron 7570
Windows 10, latest updates, latest drivers.


#2

Well, the way its supposed to work is no application should be able to have a volume higher than your master sound, but you could still control the individual volume levels through the sound mixer.

What are some of the applications having this issue? With Chrome in particular you could try disabling the ability of sites to play sound through chrome://settings/content/sound


#3

I understand that’s how it is supposed to work, but that’s not how it DOES work (at least for me…)
It’s not a specific application, all applications behave like I described until I manually decrease their volume.
Exact steps to reproduce:

  • Decrease master volume to 5%
  • Open any application that produces sound
    The application’s sound is at max volume.
    It happened with chrome, vlc, bsplayer, wow, even windows/system notifications! And the worse part is, I can’t see those notifications in the volume mixer, so they are always at 100%…

The only time applications follow the master volume, is when the master volume is completely muted. When I have it at even 1%, they won’t follow it.


#4

In addition to updating the driver, did you try to reinstall it?

Another thing you might try is running the sfc /scannow command to make sure all the Windows system files are intact:


#5

I’ll try uninstalling and reinstalling.
I am a little confused, though, as in my sound controllers I have both “Intel® Display Audio” and “Realtek High Definition Audio”.

Another weird thing I just noticed:
When plugged in HDMI, the sound coming from the TV works as expected! Master volume does control applications.
While on built-in output, however, the problem still persists.
I’ll try your suggestions and come back with the results.


#6

Another thing to consider. Has this issue always been present since you got the computer, or is it a recent issue? Could be a bad Windows update, there have been a lot of bugs with the latest Fall update in particular.


#7

It’s happened since I installed Windows (main OS is debian, sound works fine), but it hasn’t been long ago to test older versions.


#8

When was it that you installed Windows?