An unexpected error is keeping you from moving the file 0x80070057


#1

An unexpected error is keeping you from moving the file Error : 0x80070057


#2

Try a computer restart first.

If that doesn’t work try running system file checker to see if corrupt Windows system files may be causing this issue:


#3

Didn’t work.
I am trying to move data from Internal HDD to External HDD.
And Error 0x80070057 and “file names would be too long for destination” errors are showing.
“file names would be too long for destination” doesn’t happen when using long path names in internal storage but happens when transferring data to external HDD.


#4

What didn’t work exactly? Were you not able to run the command? Or did it run and not find any corrupt files? If corrupt files were found do a restart.

The paths have a character limit of 255, so you will have to take that into account when moving files from one drive to another.


#5

it ran didnt fond any corrupt files.


#6

Okay, how many files does the error occur on? Is it just one file? All files in a particular folder? Multiple folders?


#7

I am trying to move a folder so maybe “All files in a particular folder.”
But could be “Multiple folders”.


#8

Try moving or copying just one file in the folder and see if you get the error.


#9

Still the same error


#10

Right-click your desktop and go to New > Text Document

Save the file, then try to move it into that folder. If successful, try to move it back out of the folder.


#11

I am able to do that.


#12

Okay then, so there doesn’t seem to be any issues with permissions on the folder.

On the external HDD, is there currently any data on it? What file system is it formatted with?

When you tried moving one of the files out of the folder before, did you try to move it to the external drive? Or did you just try to move it outside of that folder on the internal drive?


#13

Yes there is data in external HDD.
It in FAT32 format.

To Internal but i am able to do both


#14

How big is the external drive? With FAT32 the max size is 2TB.

FAT32 also has a max file size limit of 4GB, how big is the file that you are trying to move?


#15

Its 1 TB Drive.All files are less than 4GB.


#16

So your external is FAT32, what format is your internal?

What did you mean by that response? Did your issue resolve at some point and you are able to move a file both internally and externally?